You are here

PyRosetta compiled with GLIBC 2.12

3 posts / 0 new
Last post
PyRosetta compiled with GLIBC 2.12


We are trying to install PyRosetta on CentOS 6.  The current compilation of PyRosetta (PyRosetta4.Release.python27.linux.release-171.tar.bz2) requires GLIBC_2.14.

However, our system's GLIBC version is 2.12 and the compilation of PyRosetta stop with the error

                          ImportError: /lib64/ version `GLIBC_2.14' not found (required by /cm/shared/apps/pyrosetta/python/2.7/4.171/lib/python2.7/site-packages/pyrosetta-2018.9+release.333d996-py2.7-linux-x86_64.egg/pyrosetta/

Would it be possible to get a compilation of PyRosetta with GLIBC 2.12?

Post Situation: 
Tue, 2018-03-13 15:02

It should be possible to install PyRosetta on that system but you will need to build it from Rosetta source. Please see for instructions how to do that.

Tue, 2018-03-13 16:58

We have tried to build it from Rosetta source, but we got errors in "Generating bindings", please see attached files for errors.

File attachments: 
Wed, 2018-03-14 15:35